System Requirements

Valid from version:
5.0.0

Recommendation: You can find an overview of Shopware Hosting Partners here.

If you are not sure, which hosting to get, take a look in the article "Which hosting should I use?"

Server

The required server hardware is mostly dependent on the number of articles available in your shop and on the expected traffic (visitors per day). Upon request, we'll gladly send you guidelines for suitable server equipment. These requirements are met by most modern hosting providers.

Requirements

  • Linux-based operating system with Apache 2.x web server
  • PHP 5.6.4 or higher
  • MySQL 5.5 or higher
  • Possibility to set up cron jobs
  • Minimum 4 GB available hard disk space

PHP Extensions / Web server

  • a valid, routed domain
  • Apache mod_rewrite
  • GD Library version 2.0 or higher
  • cURL Library installed
  • IonCube Loader version 5.0.0 or higher is required when using encoded third Party plugins.
  • When using Shopware ESD functionalities, it's highly recommend to use Apache X-Sendfile.

Web server/PHP-Configuration

  • memory_limit > 256M
  • magic_quotes_gpc OFF
  • allow_url_fopen activated
  • register_globals deactivated
  • Possibiliy to modify configurations by .htaccess
  • PHP Calendar Extension
  • PHP Zip Extension
  • PDO / PDO_Mysql

Please keep in mind, that these values are absolute minimum requirements, when you are using Shopware in a high-traffic-environment or you have a huge amount of items in your shop, we highly recommend to upgrade the server resources.

Other requirements

The requirements specified above reflect only the minimum requirements of Shopware. Specific hardware requirements vary depending on the size and expected traffic of your shop. Additional server configuration may be required. Plugins installed on your shop may increase Shopware's resource needs or add additional system dependencies. Please refer to each plugin's documentation for more information.

Alternative server setups

The above requirements reflect the officially supported and recommended system setup to run Shopware. However, you might be able to run Shopware on equivalent setups (Mac OS, nginx, MariaDB, etc).
Please keep in mind that we are unable to provide official support for setting up such servers and setups. The setup of such an alternative server with all mandatory system requirements is task of the respective hosting partner.

Administration client

The administration of your shop can be done completely online via the web browser. The following requirements should be met by any client system that uses the administration backend. These requirement differ from the frontend user system requirements.

Requirements

  • Firefox, Chrome, Safari or Internet Explorer version 11 or higher.
  • JavaScript and Cookies enabled
  • 4 GB RAM
  • Dual-core CPU
  • Minimum backend resolution: 1366 x 768 pixels

Suggested Items

Updating Shopware

Creating a backup Before updating Shopware, '''create a backup'''. Only with backups you can rollback easily if needed. Plugin compatibility - IMPORTANT Before updating, take care that all of your installed plugins are up-to-date and...

read more

First Run Wizard

Introduction The First Run Wizard will guide you through the setup of Shopware, where basic settings will be adapted. The First Run Wizard will only executed at the first login of an admin user after installing Shopware. After updates, the...

read more

Update Guide Shopware 5.2 to Shopware 5.3

Before updating Same procedure as every update: update your installed plugins and make a backup of your environment! Make yourself familiar with the most important changes and the area of "What will break", so you can delete deprecated stuff...

read more
$ 1,36

Prices incl. legal
VAT + Shipping rates & policies*